CompareComparing...

HTC Sense 3.0 only for newer Devices Past Generation left out

Now Reading
HTC Sense 3.0 only for newer Devices Past Generation left out

Browse This Page

Here is a big bummer from HTC, all devices including Desire HD, Incredible S or any other handset that doesn’t ship with it preloaded will not be getting the Sense 3.0 update. The company claims that the new Sense is Hardware intensive and will not work properly on last generation phones. This move could go both ways for HTC, loyalists will upgrade to new handsets and angry old customers will shift loyalties. what do you think?

What's your reaction?
Awesome
0%
Epic
0%
Like
I Want This
0%
Meh
0%
About The Author
Bharat Nagpal
Founder and Chief Editor of iGyaan. Bharat likes to keep on top of technology ! Follow Him on Google Plus : Google+